CCENT Lab Notes, Part 2

This is a log of my work on last 6 of these PackTracer labs for the ICND1 exam.

SPOILER ALERT: Do your labs first, these are notes on how I resolved them.

Lab 7

PC0 cannot ping PC1, can you fix it?

lab

I verify that both PCs can ping as far as the outward-facing interface of R3. I furthermore verify that both R3 can ping R1, but not from its inside interface.

Running sh ip route on all three routers, I see that R2 has a loopback device on the 192.168.1.0/25 network.

On R2:

R2(config)#int lo 0
R2(config-if)#shut

Lab 8

Same premise and layout. Now with VLANs.

First, there are overlapping subnets. R1’s private VLAN overlapped with the link between R2 and R3. I changed the subnet of the management VLAN, which allowed R1 to contact the 172.16.0. network, but still no communication between R1 and R3.

I checked the configs of the three routers, and there was a passive interface configured on R2, which I rectified with no passive-interface f0/1. This reminded me to add the new subnet on R1:

R1(config)#router ospf 1
R1(config-router)#network 172.16.1.1 0.0.0.0 area 0

At this point, all that’s left is to get PC0 connecting to the router. I had to add VLAN 10 to one of the switches, and set it as the default VLAN for the trunk ports on both switches.

Switch(config)#vlan 10
!
Switch(config)#int range f0/1-2
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#switchport trunk native vlan 10

Lab 9

In this lab, we have the same overlapping subnets. PC0 can ping to the 10.0.0.0/24 subnet, and PC1 can ping the inside interface of R3. No need to mess with trunking this time.

No OSPF routes, except to 192.168.0.0/24 on R2. I worked on fixing the OSPF config, but it’s an ICND2 objective, and none of the resources I found rendered any results. So I set up static routes, for example:

R2(config)#no router ospf 1
R2(config)#ip route 192.168.0.0 255.255.255.0 10.0.0.1
R2(config)#ip route 172.16.1.0 255.255.255.0 10.0.0.1
R2(config)#ip route 192.168.1.0 255.255.255.0 172.168.0.2

Lab 10

Corrected the same subnet overlap. Same OSPF issues, which I bypassed with static routes. VLANs were properly trunked, but had to add the default gateway to the dhcp pool:

R1(config)#ip dhcp pool VLAN0010
R1(dhcp-config)#default-router 192.168.0.1

Lab 11

I’m not sure what the point of this one was. This time I saved time by adding gateway of last resort to R1 and R3:

R1(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.2

Lab 12

This one is said to be tough, “more than 5 errors in one lab.”

Shutdown R3’s Loopback 0 (overlapping subnets). Fix the DHCP pool on R1 (no default gw), overlapping subnet, and extraneous access list (outbound from external subnet).

Enabled trunking with matching native VLANs on PC0’s switches. Removed duplicate OSPF IDs, and set static and default routes.

Finally, I removed the mismatched speed settings on PC1’s switches:

Switch(config)#int f0/2
Switch(config-if)#no speed 10

Conclusion

There are a few things I need to review a bit over the next couple weeks, but I’m feeling pretty good at the moment. I have a handful of other labs as well, which I will be doing.